$re = '/(\w+\s\w+|\d+.\d+)/m';
$str = 'John Doe 3.30 23123123';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);