const regex = /(WORD.*AGAIN)([^[:alnum:]]+)(CIP[^(]*\([0-9]+\))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(WORD.*AGAIN)([^[:alnum:]]+)(CIP[^(]*\\([0-9]+\\))', 'gm')
const str = ` 23 TWO-ONE2 WORD 5 AGAIN CIP D(89). 1234541120
WORD 5 AGAIN CIP F7(456).`;
const subst = `\3\2\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);