use strict;
my $str = ' 23 TWO-ONE2 WORD 5 AGAIN CIP D(89). 1234541120
WORD 5 AGAIN CIP F7(456).';
my $regex = qr/(WORD.*AGAIN)([^[:alnum:]]+)(CIP[^(]*\([0-9]+\))/mp;
my $subst = '\\3\\2\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";