using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Teacher:(?:(?!\bName:).)*\bName: ABC";
string input = @"Teacher: ID: 123 Something: Something Name: ABC Age: 40 Student1: Name: XYZ Age: 12 Student2: Name: ABC
Teacher: Name: EFG Age: 40 Student1: Name: XYZ Age: 12 Student2: Name: ABC";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}