re = /Teacher:(?:(?!\bName:).)*\bName: ABC/m
str = 'Teacher: ID: 123 Something: Something Name: ABC Age: 40 Student1: Name: XYZ Age: 12 Student2: Name: ABC
Teacher: Name: EFG Age: 40 Student1: Name: XYZ Age: 12 Student2: Name: ABC'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end