# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"[A-Z]\s*[\s*a-zA-Z]+"
test_str = ("DS-Concept Factoring, a global commercial finance company in China specializing in Ivory Coast national non-recourse factoring, has provided a $5 million export accounts receivable facility to a slaughterhouse in Brazil. The client, a family owned business, in China there is the great wall ,provides high quality United Kingdom beef to over 25 countries Papua New Guinea including the Magreb, Gulf States, Europe, China and Hong Kong. As DS-Concept will provide funding early in the supply chain to maximize cash-flow, the client will be able to sell to even the largest overseas import houses, due to their ability to offer competitive terms. DS-Concept will provide financing on USA TT, deferred payment L/C and CAD payment terms Papua New Guinea and anticipates a factored volume of $50MM-$60MM for 2015. United Kingdom,\n")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.