// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"[A-Z]\s*[\s*a-zA-Z]+").unwrap();
let string = "DS-Concept Factoring, a global commercial finance company in China specializing in Ivory Coast national non-recourse factoring, has provided a $5 million export accounts receivable facility to a slaughterhouse in Brazil. The client, a family owned business, in China there is the great wall ,provides high quality United Kingdom beef to over 25 countries Papua New Guinea including the Magreb, Gulf States, Europe, China and Hong Kong. As DS-Concept will provide funding early in the supply chain to maximize cash-flow, the client will be able to sell to even the largest overseas import houses, due to their ability to offer competitive terms. DS-Concept will provide financing on USA TT, deferred payment L/C and CAD payment terms Papua New Guinea and anticipates a factored volume of $50MM-$60MM for 2015. United Kingdom,
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}