using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"c[ae]l[ae]nd[ae]r";
string input = @"calender
calendar
calandar
calendar
celandar
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}