$re = '/00?(?:1+0{0,2})*?11[01]/m';
$str = '1000001110001011001101011000010101100001001100001111
010110';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);