re = /00?(?:1+0{0,2})*?11[01]/m
str = '1000001110001011001101011000010101100001001100001111
010110'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end