package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^[^\s^\x00-\x1f\\?*:"";<>|\/.][^\x00-\x1f\\?*:"";<>|\/]*[^\s^\x00-\x1f\\?*:"";<>|\/.]+$`)
var str = `hola`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}