re = /^[^\s^\x00-\x1f\\?*:"";<>|\/.][^\x00-\x1f\\?*:"";<>|\/]*[^\s^\x00-\x1f\\?*:"";<>|\/.]+$/
str = 'hola'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end