const regex = /Nature "([^"]+)" y=([0-9]+) x=([0-9]+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('Nature "([^"]+)" y=([0-9]+) x=([0-9]+)', 'gm')
const str = `Nature "natures/tree9" y=160 x=1440`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}