re = /Nature "([^"]+)" y=([0-9]+) x=([0-9]+)/m
str = 'Nature "natures/tree9" y=160 x=1440'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end