re = /^(.*)_([^_]+_[^_]+)__?\d$/m
str = 'CumulativeReport_cumulativeReportBins_CumulativeBinNetworksViews_totalSuccessfulHeartbeats_1
CumulativeReport_cumulativeReportBins_CumulativeBinNetworksViews_totalSuccessfulHeartbeats__1'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end