const regex = /(?=(?>(?<match1>((?>\s|\b)\w{3}\s).+\s+\s(\d+\.\d{2})\s.*\s+\s(\d{1})\s.*)))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?=(?>(?<match1>((?>\\s|\\b)\\w{3}\\s).+\\s+\\s(\\d+\\.\\d{2})\\s.*\\s+\\s(\\d{1})\\s.*)))', 'gm')
const str = `ABC FED GHK 45.00 60.00 30.00 4 5 5`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}