re = /^(?:(?!Bewerbung von|Name:|MC-Name:|Alter:|Aufgabe:|Vorteile:|GrĂ¼nde:).)*$/m
str = 'This string matches Name:'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end