using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:https.+?linktr\.ee(?:%2F|.+?/)):?\s?([a-zA-Z0-9_.-]+)";
string input = @"https:\\/\\/linktr.ee\\/BinkyBlue";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}