$re = '/(?:https.+?linktr\.ee(?:%2F|.+?/)):?\s?([a-zA-Z0-9_.-]+)/m';
$str = 'https:\\\\/\\\\/linktr.ee\\\\/BinkyBlue';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);