package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:https.+?linktr\.ee(?:%2F|.+?/)):?\s?([a-zA-Z0-9_.-]+)`)
var str = `https:\\/\\/linktr.ee\\/TESTER`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}