#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)([A-Z]+(?![a-z]))|(?<=[\da-z])(?=[A-Z])"
Local $sString = "ERISACheckL " & @CRLF & _
"ERISA404cCheckL " & @CRLF & _
"F401kC " & @CRLF & _
"DisclosureG " & @CRLF & _
"SafeHarborE"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")