$re = '/([A-Z]+(?![a-z]))|(?<=[\da-z])(?=[A-Z])/m';
$str = 'ERISACheckL
ERISA404cCheckL
F401kC
DisclosureG
SafeHarborE';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);