import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(PAI:[ \\w]+<sip:)((?:\\([2-9]\\d{2}\\) ?|[2-9]\\d{2}[ -]?)[2-9]\\d{2}[- ]?\\d{4})@";
final String string = "Accept: multipart/mixedPrivacy: nonePAI: <sip:4168755400@1.1.1.238>From: <sip:4168755400@1.1.1.238>;tag=5430960946837208_c1b08.2.3.1602135087396.0_1237422_3895152To: <sip:4168755400@1.1.1.238>\n\n"
+ "Accept: multipart/mixedPrivacy: nonePAI:test<sip:4168755400@1.1.1.238>From: <sip:4168755400@1.1.1.238>;tag=5430960946837208_c1b08.2.3.1602135087396.0_1237422_3895152To: <sip:4168755400@1.1.1.238>\n\n"
+ "Accept: multipart/mixedPrivacy: nonePAI: test <sip:4168755400@1.1.1.238>From: <sip:4168755400@1.1.1.238>;tag=5430960946837208_c1b08.2.3.1602135087396.0_1237422_3895152To: <sip:4168755400@1.1.1.238>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}