$re = '/(PAI:[ \w]+<sip:)((?:\([2-9]\d{2}\) ?|[2-9]\d{2}[ -]?)[2-9]\d{2}[- ]?\d{4})@/m';
$str = 'Accept: multipart/mixedPrivacy: nonePAI: <sip:4168755400@1.1.1.238>From: <sip:4168755400@1.1.1.238>;tag=5430960946837208_c1b08.2.3.1602135087396.0_1237422_3895152To: <sip:4168755400@1.1.1.238>
Accept: multipart/mixedPrivacy: nonePAI:test<sip:4168755400@1.1.1.238>From: <sip:4168755400@1.1.1.238>;tag=5430960946837208_c1b08.2.3.1602135087396.0_1237422_3895152To: <sip:4168755400@1.1.1.238>
Accept: multipart/mixedPrivacy: nonePAI: test <sip:4168755400@1.1.1.238>From: <sip:4168755400@1.1.1.238>;tag=5430960946837208_c1b08.2.3.1602135087396.0_1237422_3895152To: <sip:4168755400@1.1.1.238>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);