import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b\\+1-.{3}-.{3}-.{4}\\b";
final String string = "Program title: Primes\n"
+ "Author: Kern\n"
+ "Corporation: Gold\n"
+ "Phone: asas+1-503-555-0091 sad\n"
+ "Date: Tues April 9, 2005\n"
+ "Version: 6.7\n"
+ "Level: Alpha";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}