const regex = /\b\+1-.{3}-.{3}-.{4}\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b\\+1-.{3}-.{3}-.{4}\\b', 'gm')
const str = `Program title: Primes
Author: Kern
Corporation: Gold
Phone: asas+1-503-555-0091 sad
Date: Tues April 9, 2005
Version: 6.7
Level: Alpha`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}