$re = '~[^;]+;~';
$str = 'msg:"c# 6.0 is good";sid:201;classtype:object oriented;.net,ado.net,other messages';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);