re = /[^;]+;/
str = 'msg:"c# 6.0 is good";sid:201;classtype:object oriented;.net,ado.net,other messages'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end