re = /^(\S+(?:.*\b(?=[MDCLXVI])M{0,4}(?:CM|CD|D?C{0,3})(?:XC|XL|L?X{0,3})(?:IX|IV|V?I{0,3})\b(?= +\S))?) +(.*)/m
str = 'Vladimir Goth
Langraab III Landgraab
Langraab VII Landgraab
Léa Magdalena X Rouault Something
Anna Maria Teodora
Léa Maria Teodora II
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end