#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^.*\((\d*),(\d*)\)\s*:\s*(.*)"
Local $sString = "C:\Users\User\AppData\Roaming\MetaQuotes\Terminal\D0E8209F77C8CF37AD8BF550E51FF075\MQL5\Experts\TradeControl.mq5 : information: Checking 'TradeControl.mq5'" & @CRLF & _
"C:\Users\User\AppData\Roaming\MetaQuotes\Terminal\D0E8209F77C8CF37AD8BF550E51FF075\MQL5\Experts\TradeControl.mq5(25,5) : error 256: 'abc' - undeclared identifier" & @CRLF & _
"C:\Users\User\AppData\Roaming\MetaQuotes\Terminal\D0E8209F77C8CF37AD8BF550E51FF075\MQL5\Experts\TradeControl.mq5(27,4) : error 152: 'OrdersPrev' - some operator expected" & @CRLF & _
"C:\Users\User\AppData\Roaming\MetaQuotes\Terminal\D0E8209F77C8CF37AD8BF550E51FF075\MQL5\Experts\TradeControl.mq5(88,16) : warning 43: possible loss of data due to type conversion" & @CRLF & _
"C:\Users\User\AppData\Roaming\MetaQuotes\Terminal\D0E8209F77C8CF37AD8BF550E51FF075\MQL5\Experts\TradeControl.mq5(96,22) : warning 43: possible loss of data due to type conversion" & @CRLF & _
"C:\Users\User\AppData\Roaming\MetaQuotes\Terminal\D0E8209F77C8CF37AD8BF550E51FF075\MQL5\Experts\TradeControl.mq5(147,22) : warning 43: possible loss of data due to type conversion" & @CRLF & _
"C:\Users\User\AppData\Roaming\MetaQuotes\Terminal\D0E8209F77C8CF37AD8BF550E51FF075\MQL5\Experts\TradeControl.mq5(202,22) : warning 43: possible loss of data due to type conversion" & @CRLF & _
": information: Result 2 error(s), 4 warning(s)" & @CRLF & _
"[Finished in 2.7s]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")