use strict;
my $str = 'C:\\Users\\User\\AppData\\Roaming\\MetaQuotes\\Terminal\\D0E8209F77C8CF37AD8BF550E51FF075\\MQL5\\Experts\\TradeControl.mq5 : information: Checking \'TradeControl.mq5\'
C:\\Users\\User\\AppData\\Roaming\\MetaQuotes\\Terminal\\D0E8209F77C8CF37AD8BF550E51FF075\\MQL5\\Experts\\TradeControl.mq5(25,5) : error 256: \'abc\' - undeclared identifier
C:\\Users\\User\\AppData\\Roaming\\MetaQuotes\\Terminal\\D0E8209F77C8CF37AD8BF550E51FF075\\MQL5\\Experts\\TradeControl.mq5(27,4) : error 152: \'OrdersPrev\' - some operator expected
C:\\Users\\User\\AppData\\Roaming\\MetaQuotes\\Terminal\\D0E8209F77C8CF37AD8BF550E51FF075\\MQL5\\Experts\\TradeControl.mq5(88,16) : warning 43: possible loss of data due to type conversion
C:\\Users\\User\\AppData\\Roaming\\MetaQuotes\\Terminal\\D0E8209F77C8CF37AD8BF550E51FF075\\MQL5\\Experts\\TradeControl.mq5(96,22) : warning 43: possible loss of data due to type conversion
C:\\Users\\User\\AppData\\Roaming\\MetaQuotes\\Terminal\\D0E8209F77C8CF37AD8BF550E51FF075\\MQL5\\Experts\\TradeControl.mq5(147,22) : warning 43: possible loss of data due to type conversion
C:\\Users\\User\\AppData\\Roaming\\MetaQuotes\\Terminal\\D0E8209F77C8CF37AD8BF550E51FF075\\MQL5\\Experts\\TradeControl.mq5(202,22) : warning 43: possible loss of data due to type conversion
: information: Result 2 error(s), 4 warning(s)
[Finished in 2.7s]';
my $regex = qr/^.*\((\d*),(\d*)\)\s*:\s*(.*)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}