#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mis)https?:\/\/www.gamecoin.com.br/category/[\w-]+/$"
Local $sString = "https://www.gamecoin.com.br/false#cmplz-manage-consent-container" & @CRLF & _
"https://www.gamecoin.com.br/false#cmplz-cookies-overview" & @CRLF & _
"https://www.gamecoin.com.br/false#cmplz-tcf-wrapper" & @CRLF & _
"https://cookiedatabase.org/tcf/purposes/" & @CRLF & _
"https://www.gamecoin.com.br/false#cmplz-manage-consent-container" & @CRLF & _
"https://www.gamecoin.com.br/politica-de-privacidade/" & @CRLF & _
"https://www.gamecoin.com.br/#" & @CRLF & _
"https://www.gamecoin.com.br/#content" & @CRLF & _
"https://www.gamecoin.com.br/" & @CRLF & _
"https://www.gamecoin.com.br/category/noticias/" & @CRLF & _
"https://www.gamecoin.com.br/category/games-2022/" & @CRLF & _
"https://www.gamecoin.com.br/category/review/" & @CRLF & _
"https://www.gamecoin.com.br/category/jogue-outra-vez/" & @CRLF & _
"https://www.gamecoin.com.br/category/oldies/" & @CRLF & _
"https://www.gamecoin.com.br/category/mobile-2/" & @CRLF & _
"https://www.gamecoin.com.br/category/lista-gamecoin/" & @CRLF & _
"https://www.gamecoin.com.br/sobre-o-gamecoin/" & @CRLF & _
"https://www.gamecoin.com.br/politica-de-privacidade/" & @CRLF & _
"https://www.gamecoin.com.br/category/artigo/" & @CRLF & _
"https://www.gamecoin.com.br/category/artigo/" & @CRLF & _
"https://www.youtube.com/garagemdojabulas" & @CRLF & _
"https://www.gamecoin.com.br/web-stories/quem-e-o-cara-do-doom%3f/" & @CRLF & _
"https://www.gamecoin.com.br/category/noticias/" & @CRLF & _
"https://www.gamecoin.com.br/jogue-outra-vez-spider-man-ps4-ps5-pc/" & @CRLF & _
"https://www.gamecoin.com.br/hbo-max-the-last-of-us-em-carne-osso-luzes-e-acao/" & @CRLF & _
"https://www.gamecoin.com.br/category/oldies/" & @CRLF & _
"https://www.gamecoin.com.br/super-contra-chega-aos-35-anos-e-poucos-viram-os-creditos/" & @CRLF & _
"https://www.gamecoin.com.br/category/oldies/" & @CRLF & _
"https://www.gamecoin.com.br/game-stick-super-nintendo/" & @CRLF & _
"https://www.gamecoin.com.br/jogue-outra-vez-spider-man-ps4-ps5-pc/" & @CRLF & _
"https://www.gamecoin.com.br/pokemon-scarlet/" & @CRLF & _
"https://www.gamecoin.com.br/shadow-samurai-revenge/" & @CRLF & _
"https://www.gamecoin.com.br/review-jogamos-sonic-frontiers-no-nintendo-switch/" & @CRLF & _
"https://www.gamecoin.com.br/category/oldies/" & @CRLF & _
"https://www.gamecoin.com.br/super-contra-chega-aos-35-anos-e-poucos-viram-os-creditos/" & @CRLF & _
"https://www.gamecoin.com.br/super-contra-chega-aos-35-anos-e-poucos-viram-os-creditos/" & @CRLF & _
"https://www.gamecoin.com.br/author/marcelo/" & @CRLF & _
"https://www.gamecoin.com.br/category/oldies/" & @CRLF & _
"https://www.gamecoin.com.br/game-stick-super-nintendo/" & @CRLF & _
"https://www.gamecoin.com.br/game-stick-super-nintendo/" & @CRLF & _
"https://www.gamecoin.com.br/author/marcelo/" & @CRLF & _
"https://www.gamecoin.com.br/category/oldies/" & @CRLF & _
"https://www.gamecoin.com.br/flashback-30-anos/" & @CRLF & _
"https://www.gamecoin.com.br/flashback-30-anos/" & @CRLF & _
"https://www.gamecoin.com.br/author/marcelo/" & @CRLF & _
"https://www.gamecoin.com.br/category/mobile-2/" & @CRLF & _
"https://www.gamecoin.com.br/category/oldies/" & @CRLF & _
"https://www.gamecoin.com.br/super-mario-land-game-boy/" & @CRLF & _
"https://www.gamecoin.com.br/super-mario-land-game-boy/" & @CRLF & _
"https://www.gamecoin.com.br/author/marcelo/" & @CRLF & _
"https://www.gamecoin.com.br/category/oldies/" & @CRLF & _
"https://www.gamecoin.com.br/gran-turismo-25-anos/" & @CRLF & _
"https://www.gamecoin.com.br/gran-turismo-25-anos/" & @CRLF & _
"https://www.gamecoin.com.br/author/marcelo/" & @CRLF & _
"https://www.gamecoin.com.br/category/noticias/" & @CRLF & _
"https://www.gamecoin.com.br/jogue-outra-vez-spider-man-ps4-ps5-pc/" & @CRLF & _
"https://www.gamecoin.com.br/jogue-outra-vez-spider-man-ps4-ps5-pc/" & @CRLF & _
"https://www.gamecoin.com.br/author/marcelo/" & @CRLF & _
"https://www.gamecoin.com.br/dead-island-jogue-outra-vez/" & @CRLF & _
"https://www.gamecoin.com.br/dead-island-jogue-outra-vez/" & @CRLF & _
"https://www.gamecoin.com.br/author/marcelo/" & @CRLF & _
"https://www.gamecoin.com.br/jogue-outra-vez-castlevania-lords-of-shadow/" & @CRLF & _
"https://www.gamecoin.com.br/jogue-outra-vez-castlevania-lords-of-shadow/" & @CRLF & _
"https://www.gamecoin.com.br/author/marcelo/" & @CRLF & _
"https://www.gamecoin.com.br/jogue-outra-vez-o-assustador-the-evil-within/" & @CRLF & _
"https://www.gamecoin.com.br/jogue-outra-vez-o-assustador-the-evil-within/" & @CRLF & _
"https://www.gamecoin.com.br/author/marcelo/" & @CRLF & _
"https://www.gamecoin.com.br/category/oldies/" & @CRLF & _
"https://www.gamecoin.com.br/10-anos-de-call-of-duty-black-ops/" & @CRLF & _
"https://www.gamecoin.com.br/10-anos-de-call-of-duty-black-ops/" & @CRLF & _
"https://www.gamecoin.com.br/author/marcelo/" & @CRLF & _
"https://www.gamecoin.com.br/super-mario-land-game-boy/" & @CRLF & _
"https://www.gamecoin.com.br/pokemon-scarlet/" & @CRLF & _
"https://www.gamecoin.com.br/shadow-samurai-revenge/" & @CRLF & _
"https://www.gamecoin.com.br/return-to-monkey-island/" & @CRLF & _
"https://www.gamecoin.com.br/category/lista-gamecoin/" & @CRLF & _
"https://www.gamecoin.com.br/10-games-para-esperar-gta-6-chegar/" & @CRLF & _
"https://www.gamecoin.com.br/10-games-para-esperar-gta-6-chegar/" & @CRLF & _
"https://www.gamecoin.com.br/author/marcelo/" & @CRLF & _
"https://www.gamecoin.com.br/category/lista-gamecoin/" & @CRLF & _
"https://www.gamecoin.com.br/10-games-da-franquia-alien-para-jogar/" & @CRLF & _
"https://www.gamecoin.com.br/10-games-da-franquia-alien-para-jogar/" & @CRLF & _
"https://www.gamecoin.com.br/author/marcelo/" & @CRLF & _
"https://www.gamecoin.com.br/category/lista-gamecoin/" & @CRLF & _
"https://www.gamecoin.com.br/super-herois-10-games-de-para-mega-drive-e-snes/" & @CRLF & _
"https://www.gamecoin.com.br/super-herois-10-games-de-para-mega-drive-e-snes/" & @CRLF & _
"https://www.gamecoin.com.br/author/marcelo/" & @CRLF & _
"https://www.gamecoin.com.br/category/lista-gamecoin/" & @CRLF & _
"https://www.gamecoin.com.br/batman-10-games-do-homem-morcego/" & @CRLF & _
"https://www.gamecoin.com.br/batman-10-games-do-homem-morcego/" & @CRLF & _
"https://www.gamecoin.com.br/author/marcelo/" & @CRLF & _
"https://www.gamecoin.com.br/category/lista-gamecoin/" & @CRLF & _
"https://www.gamecoin.com.br/category/noticias/" & @CRLF & _
"https://www.gamecoin.com.br/8-de-marco-quatro-games-para-lutar-como-uma-garota/" & @CRLF & _
"https://www.gamecoin.com.br/8-de-marco-quatro-games-para-lutar-como-uma-garota/" & @CRLF & _
"https://www.gamecoin.com.br/author/marcelo/" & @CRLF & _
"https://www.gamecoin.com.br/assinatura-de-games-e-locadora-da-era-digital/" & @CRLF & _
"https://www.gamecoin.com.br/assinatura-de-games-e-locadora-da-era-digital/" & @CRLF & _
"https://www.gamecoin.com.br/author/marcelo/" & @CRLF & _
"https://www.gamecoin.com.br/category/lista-gamecoin/" & @CRLF & _
"https://www.gamecoin.com.br/category/noticias/" & @CRLF & _
"https://www.gamecoin.com.br/simulador-simcade-e-arcade-as-diferencas-entre-cada-estilo/" & @CRLF & _
"https://www.gamecoin.com.br/simulador-simcade-e-arcade-as-diferencas-entre-cada-estilo/" & @CRLF & _
"https://www.gamecoin.com.br/author/marcelo/" & @CRLF & _
"https://www.gamecoin.com.br/category/noticias/" & @CRLF & _
"https://www.gamecoin.com.br/doom-coelhinhas-e-minecraft/" & @CRLF & _
"https://www.gamecoin.com.br/doom-coelhinhas-e-minecraft/" & @CRLF & _
"https://www.gamecoin.com.br/author/marcelo/" & @CRLF & _
"https://www.gamecoin.com.br/category/oldies/" & @CRLF & _
"https://www.gamecoin.com.br/the-witcher-iii-os-segredos-que-fazem-dele-o-melhor-jogo-da-geracao/" & @CRLF & _
"https://www.gamecoin.com.br/the-witcher-iii-os-segredos-que-fazem-dele-o-melhor-jogo-da-geracao/" & @CRLF & _
"https://www.gamecoin.com.br/author/marcelo/" & @CRLF & _
"https://www.gamecoin.com.br/e3-para-elas/" & @CRLF & _
"https://www.gamecoin.com.br/e3-para-elas/" & @CRLF & _
"https://www.gamecoin.com.br/author/marcelo/" & @CRLF & _
"https://www.gamecoin.com.br/category/oldies/" & @CRLF & _
"https://www.gamecoin.com.br/30-anos-de-the-addams-family-nos-games/" & @CRLF & _
"https://www.gamecoin.com.br/30-anos-de-the-addams-family-nos-games/" & @CRLF & _
"https://www.gamecoin.com.br/author/marcelo/" & @CRLF & _
"https://www.gamecoin.com.br/pipoca-e-joystick-the-hunt-for-red-october/" & @CRLF & _
"https://www.gamecoin.com.br/pipoca-e-joystick-the-hunt-for-red-october/" & @CRLF & _
"https://www.gamecoin.com.br/author/marcelo/" & @CRLF & _
"https://www.gamecoin.com.br/category/noticias/" & @CRLF & _
"https://www.gamecoin.com.br/category/oldies/" & @CRLF & _
"https://www.gamecoin.com.br/robocop-3/" & @CRLF & _
"https://www.gamecoin.com.br/robocop-3/" & @CRLF & _
"https://www.gamecoin.com.br/author/marcelo/" & @CRLF & _
"https://www.gamecoin.com.br/category/noticias/" & @CRLF & _
"https://www.gamecoin.com.br/category/oldies/" & @CRLF & _
"https://www.gamecoin.com.br/terminator/" & @CRLF & _
"https://www.gamecoin.com.br/terminator/" & @CRLF & _
"https://www.gamecoin.com.br/author/marcelo/" & @CRLF & _
"https://www.gamecoin.com.br/category/noticias/" & @CRLF & _
"https://www.gamecoin.com.br/iron-man/" & @CRLF & _
"https://www.gamecoin.com.br/iron-man/" & @CRLF & _
"https://www.gamecoin.com.br/author/marcelo/" & @CRLF & _
"https://www.gamecoin.com.br/jogue-outra-vez-spider-man-ps4-ps5-pc/" & @CRLF & _
"https://www.gamecoin.com.br/hbo-max-the-last-of-us-em-carne-osso-luzes-e-acao/" & @CRLF & _
"https://www.gamecoin.com.br/super-contra-chega-aos-35-anos-e-poucos-viram-os-creditos/" & @CRLF & _
"https://www.gamecoin.com.br/game-stick-super-nintendo/" & @CRLF & _
"https://www.gamecoin.com.br/flashback-30-anos/" & @CRLF & _
"https://www.gamecoin.com.br/super-mario-land-game-boy/" & @CRLF & _
"https://www.gamecoin.com.br/gran-turismo-25-anos/" & @CRLF & _
"https://www.gamecoin.com.br/pokemon-scarlet/" & @CRLF & _
"https://www.gamecoin.com.br/need-for-speed-unbound/" & @CRLF & _
"https://www.gamecoin.com.br/shadow-samurai-revenge/" & @CRLF & _
"https://www.gamecoin.com.br/gta-25-anos/" & @CRLF & _
"https://www.gamecoin.com.br/review-jogamos-sonic-frontiers-no-nintendo-switch/" & @CRLF & _
"https://www.gamecoin.com.br/splinter-cell-20-anos/" & @CRLF & _
"https://www.gamecoin.com.br/call-of-duty-modern-warfare-2/" & @CRLF & _
"https://www.gamecoin.com.br/god-of-war-ragnarok/" & @CRLF & _
"https://www.gamecoin.com.br/gta-san-andreas/" & @CRLF & _
"https://www.gamecoin.com.br/return-to-monkey-island/" & @CRLF & _
"https://www.gamecoin.com.br/mortal-kombat-30-anos/" & @CRLF & _
"https://www.gamecoin.com.br/super-mario-kart-30-anos/" & @CRLF & _
"https://www.gamecoin.com.br/nintendo-switch-lite-e-toda-infancia-no-bolso/" & @CRLF & _
"https://www.gamecoin.com.br/street-fighter-35-anos/" & @CRLF & _
"https://www.gamecoin.com.br/after-burner-35-anos/" & @CRLF & _
"https://www.gamecoin.com.br/indiana-jones-and-the-fate-of-atlantis-chega-aos-30-anos/" & @CRLF & _
"https://www.gamecoin.com.br/diablo-immortal-jogamos-no-a53-s20-e-redmi/" & @CRLF & _
"https://mantrabrain.com/" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")