// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mis)https?:\/\/www.gamecoin.com.br/category/[\w-]+/$").unwrap();
let string = "https://www.gamecoin.com.br/false#cmplz-manage-consent-container
https://www.gamecoin.com.br/false#cmplz-cookies-overview
https://www.gamecoin.com.br/false#cmplz-tcf-wrapper
https://cookiedatabase.org/tcf/purposes/
https://www.gamecoin.com.br/false#cmplz-manage-consent-container
https://www.gamecoin.com.br/politica-de-privacidade/
https://www.gamecoin.com.br/#
https://www.gamecoin.com.br/#content
https://www.gamecoin.com.br/
https://www.gamecoin.com.br/category/noticias/
https://www.gamecoin.com.br/category/games-2022/
https://www.gamecoin.com.br/category/review/
https://www.gamecoin.com.br/category/jogue-outra-vez/
https://www.gamecoin.com.br/category/oldies/
https://www.gamecoin.com.br/category/mobile-2/
https://www.gamecoin.com.br/category/lista-gamecoin/
https://www.gamecoin.com.br/sobre-o-gamecoin/
https://www.gamecoin.com.br/politica-de-privacidade/
https://www.gamecoin.com.br/category/artigo/
https://www.gamecoin.com.br/category/artigo/
https://www.youtube.com/garagemdojabulas
https://www.gamecoin.com.br/web-stories/quem-e-o-cara-do-doom%3f/
https://www.gamecoin.com.br/category/noticias/
https://www.gamecoin.com.br/jogue-outra-vez-spider-man-ps4-ps5-pc/
https://www.gamecoin.com.br/hbo-max-the-last-of-us-em-carne-osso-luzes-e-acao/
https://www.gamecoin.com.br/category/oldies/
https://www.gamecoin.com.br/super-contra-chega-aos-35-anos-e-poucos-viram-os-creditos/
https://www.gamecoin.com.br/category/oldies/
https://www.gamecoin.com.br/game-stick-super-nintendo/
https://www.gamecoin.com.br/jogue-outra-vez-spider-man-ps4-ps5-pc/
https://www.gamecoin.com.br/pokemon-scarlet/
https://www.gamecoin.com.br/shadow-samurai-revenge/
https://www.gamecoin.com.br/review-jogamos-sonic-frontiers-no-nintendo-switch/
https://www.gamecoin.com.br/category/oldies/
https://www.gamecoin.com.br/super-contra-chega-aos-35-anos-e-poucos-viram-os-creditos/
https://www.gamecoin.com.br/super-contra-chega-aos-35-anos-e-poucos-viram-os-creditos/
https://www.gamecoin.com.br/author/marcelo/
https://www.gamecoin.com.br/category/oldies/
https://www.gamecoin.com.br/game-stick-super-nintendo/
https://www.gamecoin.com.br/game-stick-super-nintendo/
https://www.gamecoin.com.br/author/marcelo/
https://www.gamecoin.com.br/category/oldies/
https://www.gamecoin.com.br/flashback-30-anos/
https://www.gamecoin.com.br/flashback-30-anos/
https://www.gamecoin.com.br/author/marcelo/
https://www.gamecoin.com.br/category/mobile-2/
https://www.gamecoin.com.br/category/oldies/
https://www.gamecoin.com.br/super-mario-land-game-boy/
https://www.gamecoin.com.br/super-mario-land-game-boy/
https://www.gamecoin.com.br/author/marcelo/
https://www.gamecoin.com.br/category/oldies/
https://www.gamecoin.com.br/gran-turismo-25-anos/
https://www.gamecoin.com.br/gran-turismo-25-anos/
https://www.gamecoin.com.br/author/marcelo/
https://www.gamecoin.com.br/category/noticias/
https://www.gamecoin.com.br/jogue-outra-vez-spider-man-ps4-ps5-pc/
https://www.gamecoin.com.br/jogue-outra-vez-spider-man-ps4-ps5-pc/
https://www.gamecoin.com.br/author/marcelo/
https://www.gamecoin.com.br/dead-island-jogue-outra-vez/
https://www.gamecoin.com.br/dead-island-jogue-outra-vez/
https://www.gamecoin.com.br/author/marcelo/
https://www.gamecoin.com.br/jogue-outra-vez-castlevania-lords-of-shadow/
https://www.gamecoin.com.br/jogue-outra-vez-castlevania-lords-of-shadow/
https://www.gamecoin.com.br/author/marcelo/
https://www.gamecoin.com.br/jogue-outra-vez-o-assustador-the-evil-within/
https://www.gamecoin.com.br/jogue-outra-vez-o-assustador-the-evil-within/
https://www.gamecoin.com.br/author/marcelo/
https://www.gamecoin.com.br/category/oldies/
https://www.gamecoin.com.br/10-anos-de-call-of-duty-black-ops/
https://www.gamecoin.com.br/10-anos-de-call-of-duty-black-ops/
https://www.gamecoin.com.br/author/marcelo/
https://www.gamecoin.com.br/super-mario-land-game-boy/
https://www.gamecoin.com.br/pokemon-scarlet/
https://www.gamecoin.com.br/shadow-samurai-revenge/
https://www.gamecoin.com.br/return-to-monkey-island/
https://www.gamecoin.com.br/category/lista-gamecoin/
https://www.gamecoin.com.br/10-games-para-esperar-gta-6-chegar/
https://www.gamecoin.com.br/10-games-para-esperar-gta-6-chegar/
https://www.gamecoin.com.br/author/marcelo/
https://www.gamecoin.com.br/category/lista-gamecoin/
https://www.gamecoin.com.br/10-games-da-franquia-alien-para-jogar/
https://www.gamecoin.com.br/10-games-da-franquia-alien-para-jogar/
https://www.gamecoin.com.br/author/marcelo/
https://www.gamecoin.com.br/category/lista-gamecoin/
https://www.gamecoin.com.br/super-herois-10-games-de-para-mega-drive-e-snes/
https://www.gamecoin.com.br/super-herois-10-games-de-para-mega-drive-e-snes/
https://www.gamecoin.com.br/author/marcelo/
https://www.gamecoin.com.br/category/lista-gamecoin/
https://www.gamecoin.com.br/batman-10-games-do-homem-morcego/
https://www.gamecoin.com.br/batman-10-games-do-homem-morcego/
https://www.gamecoin.com.br/author/marcelo/
https://www.gamecoin.com.br/category/lista-gamecoin/
https://www.gamecoin.com.br/category/noticias/
https://www.gamecoin.com.br/8-de-marco-quatro-games-para-lutar-como-uma-garota/
https://www.gamecoin.com.br/8-de-marco-quatro-games-para-lutar-como-uma-garota/
https://www.gamecoin.com.br/author/marcelo/
https://www.gamecoin.com.br/assinatura-de-games-e-locadora-da-era-digital/
https://www.gamecoin.com.br/assinatura-de-games-e-locadora-da-era-digital/
https://www.gamecoin.com.br/author/marcelo/
https://www.gamecoin.com.br/category/lista-gamecoin/
https://www.gamecoin.com.br/category/noticias/
https://www.gamecoin.com.br/simulador-simcade-e-arcade-as-diferencas-entre-cada-estilo/
https://www.gamecoin.com.br/simulador-simcade-e-arcade-as-diferencas-entre-cada-estilo/
https://www.gamecoin.com.br/author/marcelo/
https://www.gamecoin.com.br/category/noticias/
https://www.gamecoin.com.br/doom-coelhinhas-e-minecraft/
https://www.gamecoin.com.br/doom-coelhinhas-e-minecraft/
https://www.gamecoin.com.br/author/marcelo/
https://www.gamecoin.com.br/category/oldies/
https://www.gamecoin.com.br/the-witcher-iii-os-segredos-que-fazem-dele-o-melhor-jogo-da-geracao/
https://www.gamecoin.com.br/the-witcher-iii-os-segredos-que-fazem-dele-o-melhor-jogo-da-geracao/
https://www.gamecoin.com.br/author/marcelo/
https://www.gamecoin.com.br/e3-para-elas/
https://www.gamecoin.com.br/e3-para-elas/
https://www.gamecoin.com.br/author/marcelo/
https://www.gamecoin.com.br/category/oldies/
https://www.gamecoin.com.br/30-anos-de-the-addams-family-nos-games/
https://www.gamecoin.com.br/30-anos-de-the-addams-family-nos-games/
https://www.gamecoin.com.br/author/marcelo/
https://www.gamecoin.com.br/pipoca-e-joystick-the-hunt-for-red-october/
https://www.gamecoin.com.br/pipoca-e-joystick-the-hunt-for-red-october/
https://www.gamecoin.com.br/author/marcelo/
https://www.gamecoin.com.br/category/noticias/
https://www.gamecoin.com.br/category/oldies/
https://www.gamecoin.com.br/robocop-3/
https://www.gamecoin.com.br/robocop-3/
https://www.gamecoin.com.br/author/marcelo/
https://www.gamecoin.com.br/category/noticias/
https://www.gamecoin.com.br/category/oldies/
https://www.gamecoin.com.br/terminator/
https://www.gamecoin.com.br/terminator/
https://www.gamecoin.com.br/author/marcelo/
https://www.gamecoin.com.br/category/noticias/
https://www.gamecoin.com.br/iron-man/
https://www.gamecoin.com.br/iron-man/
https://www.gamecoin.com.br/author/marcelo/
https://www.gamecoin.com.br/jogue-outra-vez-spider-man-ps4-ps5-pc/
https://www.gamecoin.com.br/hbo-max-the-last-of-us-em-carne-osso-luzes-e-acao/
https://www.gamecoin.com.br/super-contra-chega-aos-35-anos-e-poucos-viram-os-creditos/
https://www.gamecoin.com.br/game-stick-super-nintendo/
https://www.gamecoin.com.br/flashback-30-anos/
https://www.gamecoin.com.br/super-mario-land-game-boy/
https://www.gamecoin.com.br/gran-turismo-25-anos/
https://www.gamecoin.com.br/pokemon-scarlet/
https://www.gamecoin.com.br/need-for-speed-unbound/
https://www.gamecoin.com.br/shadow-samurai-revenge/
https://www.gamecoin.com.br/gta-25-anos/
https://www.gamecoin.com.br/review-jogamos-sonic-frontiers-no-nintendo-switch/
https://www.gamecoin.com.br/splinter-cell-20-anos/
https://www.gamecoin.com.br/call-of-duty-modern-warfare-2/
https://www.gamecoin.com.br/god-of-war-ragnarok/
https://www.gamecoin.com.br/gta-san-andreas/
https://www.gamecoin.com.br/return-to-monkey-island/
https://www.gamecoin.com.br/mortal-kombat-30-anos/
https://www.gamecoin.com.br/super-mario-kart-30-anos/
https://www.gamecoin.com.br/nintendo-switch-lite-e-toda-infancia-no-bolso/
https://www.gamecoin.com.br/street-fighter-35-anos/
https://www.gamecoin.com.br/after-burner-35-anos/
https://www.gamecoin.com.br/indiana-jones-and-the-fate-of-atlantis-chega-aos-30-anos/
https://www.gamecoin.com.br/diablo-immortal-jogamos-no-a53-s20-e-redmi/
https://mantrabrain.com/
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}