const regex = /^[A-Z]{4,5}_((?![^_]*(?i:test))[^_]*)_\d{6}_\d_.{2}\d_.{2}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[A-Z]{4,5}_((?![^_]*(?i:test))[^_]*)_\\d{6}_\\d_.{2}\\d_.{2}$', 'gm')
const str = `ABCD_EFGHI-78-32#1-R77.2_301009_1_AB3_CD`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}