re = /^[A-Z]{4,5}_((?![^_]*(?i:test))[^_]*)_\d{6}_\d_.{2}\d_.{2}$/m
str = 'ABCD_EFGHI-78-32#1-R77.2_301009_1_AB3_CD'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end