package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\w*?(?:tion|ex|ph|ost|ast|ist)\w*`)
var str = `This functions as expected`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}