$re = '/\w*?(?:tion|ex|ph|ost|ast|ist)\w*/m';
$str = 'This functions as expected';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);