using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"%[^:]:$%d$$%[^:]:";
string input = @"pyc2:$6$$Tnq7a6/C1wwyKyt0V/.BP/:";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}