$re = '/%[^:]:$%d$$%[^:]:/';
$str = 'pyc2:$6$$Tnq7a6/C1wwyKyt0V/.BP/:';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);