using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<ref name=\Wfoo\W>ABC</ref>|<ref name=\Wbaz\W/>|<ref name=\Wfoo\W/>|<ref name=\Wbaz\W>ABC</ref>";
string substitution = @"";
string input = @"Foo<ref name=""foo"">ABC</ref>ABC, foo bar<ref name=""bar"">XYZ</ref>, baz<ref name=""baz""/>, qux<ref name=""foo""/>, quux<ref name=""bar""/><ref name=""baz"">ABC</ref>.";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}