const regex = new RegExp('<ref name=\\Wfoo\\W>ABC</ref>|<ref name=\\Wbaz\\W/>|<ref name=\\Wfoo\\W/>|<ref name=\\Wbaz\\W>ABC</ref>', 'gm')
const str = `Foo<ref name="foo">ABC</ref>ABC, foo bar<ref name="bar">XYZ</ref>, baz<ref name="baz"/>, qux<ref name="foo"/>, quux<ref name="bar"/><ref name="baz">ABC</ref>.`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);