const regex = /\b(?'verb'build|make|implementing)\s*
(?'build'(?:(?!(?&verb)).)*?)
(?=\s*\b(?:in|on)\b)
/igs;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(?\'verb\'build|make|implementing)\\s*
(?\'build\'(?:(?!(?&verb)).)*?)
(?=\\s*\\b(?:in|on)\\b)
', 'igs')
const str = `Projects I've built & Plan to build. HackMatch.io (May 2020 onward), As of October 2020, I intend to start implementing "Natural Language Processing" algorithms in PHP when I have time. I'll then use PHP to upload the results to big data tech (e.g. BigQuery) to create some data visualizations.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}