re = /\b(?'verb'build|make|implementing)\s*
(?'build'(?:(?!(?&verb)).)*?)
(?=\s*\b(?:in|on)\b)
/ix
str = 'Projects I\'ve built & Plan to build. HackMatch.io (May 2020 onward), As of October 2020, I intend to start implementing "Natural Language Processing" algorithms in PHP when I have time. I\'ll then use PHP to upload the results to big data tech (e.g. BigQuery) to create some data visualizations.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end