$re = '/(.*?)-\d+.*/m';
$str = 'deneme-yazi-1987.html';
$subst = "$1/";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;