import re
regex = re.compile(r"(.*?)-\d+.*", flags=re.MULTILINE)
test_str = "deneme-yazi-1987.html"
subst = "$1/"
result = regex.sub(subst, test_str)
if result:
print(result)