package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)code=(.+)`)
var str = `http://localhost:3000/?code=85b1a3645tgreg1f54221d8d9f54923b88ade29945yttrtgdg903`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}