re = /code=(.+)/m
str = 'http://localhost:3000/?code=85b1a3645tgreg1f54221d8d9f54923b88ade29945yttrtgdg903'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end