$re = '/\b(COLOR="[a-zA-Z]+)[^\n"]*"/m';
$str = 'COLOR="WHITE 화이트", DETAIL="NONE"
SLEEVE="SHORT 쇼트", COLOR="BLUE"
SLEEVE="LONG", COLOR="GRAY", TOP="DOUBLE"
COLOR="YELLOW 노랑"
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);