// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)\b(COLOR="[a-zA-Z]+)[^\n"]*""#).unwrap();
let string = "COLOR=\"WHITE 화이트\", DETAIL=\"NONE\"
SLEEVE=\"SHORT 쇼트\", COLOR=\"BLUE\"
SLEEVE=\"LONG\", COLOR=\"GRAY\", TOP=\"DOUBLE\"
COLOR=\"YELLOW 노랑\"
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}