package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m).*\\([^\ ]+)`)
var str = `\\D6-DC\Users$\name\Profile\Desktop\New folder\XXX-XX-XX-XXX OP1 RAN.NC`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}